summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorTavian Barnes <tavianator@gmail.com>2009-09-18 19:47:51 +0000
committerTavian Barnes <tavianator@gmail.com>2009-09-18 19:47:51 +0000
commite2fa7956b87c23a8229926f39a3863ecd4d4752a (patch)
tree89008fd214693cf8b5df22b9b492fcd3f394e0cb /src/Makefile.am
parent25052f0997c75f91846511041cf4eeb20959ae96 (diff)
downloadlibsandglass-e2fa7956b87c23a8229926f39a3863ecd4d4752a.tar.xz
Add timespec helper routines.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index d1a0109..a91e2b6 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -24,7 +24,11 @@ nobase_include_HEADERS = sandglass.h
libsandglass_la_SOURCES = sandglass.h \
sandglass_impl.h \
sandglass.c \
- tsc.c
+ timespec.c
+
+if TSC
+ libsandglass_la_SOURCES += tsc.c
+endif
if X86
libsandglass_la_SOURCES += x86/tsc-x86.s