summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index d1a0109..a91e2b6 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -24,7 +24,11 @@ nobase_include_HEADERS = sandglass.h
libsandglass_la_SOURCES = sandglass.h \
sandglass_impl.h \
sandglass.c \
- tsc.c
+ timespec.c
+
+if TSC
+ libsandglass_la_SOURCES += tsc.c
+endif
if X86
libsandglass_la_SOURCES += x86/tsc-x86.s