summaryrefslogtreecommitdiffstats
path: root/dimension/Makefile.am
diff options
context:
space:
mode:
authorTavian Barnes <tavianator@gmail.com>2011-05-15 16:10:51 -0600
committerTavian Barnes <tavianator@gmail.com>2011-05-15 16:10:51 -0600
commite5e88afdbf158e6df8f8c3328f308512819d9cf3 (patch)
tree2a011762c07c0087defcdc1f1022ffe32d532f49 /dimension/Makefile.am
parenta5a6b94c038e01ebf1e2de0a0774a69b02fb8e1e (diff)
downloaddimension-e5e88afdbf158e6df8f8c3328f308512819d9cf3.tar.xz
Rip out old client.
Diffstat (limited to 'dimension/Makefile.am')
-rw-r--r--dimension/Makefile.am88
1 files changed, 0 insertions, 88 deletions
diff --git a/dimension/Makefile.am b/dimension/Makefile.am
deleted file mode 100644
index 72aaad9..0000000
--- a/dimension/Makefile.am
+++ /dev/null
@@ -1,88 +0,0 @@
-###########################################################################
-## Copyright (C) 2009-2010 Tavian Barnes <tavianator@tavianator.com> ##
-## ##
-## This file is part of The Dimension Build Suite. ##
-## ##
-## The Dimension Build Suite is free software; you can redistribute it ##
-## and/or modify it under the terms of the GNU General Public License as ##
-## published by the Free Software Foundation; either version 3 of the ##
-## License, or (at your option) any later version. ##
-## ##
-## The Dimension Build Suite is distributed in the hope that it will be ##
-## useful, but WITHOUT ANY WARRANTY; without even the implied warranty ##
-## of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU ##
-## General Public License for more details. ##
-## ##
-## You should have received a copy of the GNU General Public License ##
-## along with this program. If not, see <http://www.gnu.org/licenses/>. ##
-###########################################################################
-
-SUBDIRS = bench \
- tests
-
-# Make dmnsn_error() backtraces useful
-AM_LDFLAGS = -rdynamic
-
-INCLUDES = -I$(top_srcdir)/libdimension
-
-bin_PROGRAMS = dimension
-
-AM_YFLAGS = -d
-BUILT_SOURCES = directives.h grammar.h
-EXTRA_DIST = common.prologue \
- common.declarations \
- common.terminals \
- common.nonterminals \
- common.rules \
- directives.prologue \
- directives.declarations \
- directives.nonterminals \
- directives.rules \
- grammar.prologue \
- grammar.declarations \
- grammar.nonterminals \
- grammar.rules \
- grammar.epilogue
-
-grammar.y: grammar.prologue grammar.declarations grammar.nonterminals grammar.rules grammar.epilogue common.prologue common.declarations common.terminals common.nonterminals common.rules
- @echo "%{" >$@
- @cat {common,grammar}.prologue >>$@
- @echo "%}" >>$@
- @cat common.terminals {grammar,common}.{declarations,nonterminals} >>$@
- @echo "%%" >>$@
- @cat grammar.rules common.rules >>$@
- @echo "%%" >>$@
- @cat grammar.epilogue >>$@
-
-directives.y: directives.prologue directives.declarations directives.nonterminals directives.rules common.prologue common.declarations common.terminals common.nonterminals common.rules
- @echo "%{" >$@
- @cat {common,directives}.prologue >>$@
- @echo "%}" >>$@
- @cat common.terminals {directives,common}.{declarations,nonterminals} >>$@
- @echo "%%" >>$@
- @cat directives.rules common.rules >>$@
-
-dimension_SOURCES = directives.y \
- grammar.y \
- lexer.l \
- main.c \
- parse.c \
- parse.h \
- platform.c \
- platform.h \
- progressbar.c \
- progressbar.h \
- realize.c \
- realize.h \
- tokenize.c \
- tokenize.h \
- utility.c \
- utility.h \
- y.tab.h
-dimension_LDADD = $(top_builddir)/libdimension/libdimension.la
-dimension_LDFLAGS = $(AM_LDFLAGS)
-
-bench: all-recursive
- cd bench && $(MAKE) $(AM_MAKEFLAGS) bench
-
-.PHONY: bench