summaryrefslogtreecommitdiffstats
path: root/dimension/Makefile.am
diff options
context:
space:
mode:
authorTavian Barnes <tavianator@gmail.com>2011-05-15 15:54:56 -0600
committerTavian Barnes <tavianator@gmail.com>2011-05-15 15:58:05 -0600
commita5a6b94c038e01ebf1e2de0a0774a69b02fb8e1e (patch)
tree66a4b977fff9f0119456b6c5a3398d25976f6c53 /dimension/Makefile.am
parent130cbc32499ade9235873bc5d575816f80636916 (diff)
downloaddimension-a5a6b94c038e01ebf1e2de0a0774a69b02fb8e1e.tar.xz
Group tests and benchmarks with the corresponding source code.
Diffstat (limited to 'dimension/Makefile.am')
-rw-r--r--dimension/Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/dimension/Makefile.am b/dimension/Makefile.am
index 4eaf64a..72aaad9 100644
--- a/dimension/Makefile.am
+++ b/dimension/Makefile.am
@@ -17,6 +17,9 @@
## along with this program. If not, see <http://www.gnu.org/licenses/>. ##
###########################################################################
+SUBDIRS = bench \
+ tests
+
# Make dmnsn_error() backtraces useful
AM_LDFLAGS = -rdynamic
@@ -78,3 +81,8 @@ dimension_SOURCES = directives.y \
y.tab.h
dimension_LDADD = $(top_builddir)/libdimension/libdimension.la
dimension_LDFLAGS = $(AM_LDFLAGS)
+
+bench: all-recursive
+ cd bench && $(MAKE) $(AM_MAKEFLAGS) bench
+
+.PHONY: bench