summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorTavian Barnes <tavianator@gmail.com>2010-11-12 02:32:52 -0500
committerTavian Barnes <tavianator@gmail.com>2010-11-12 02:32:52 -0500
commit20a55aa78050d94b187d4edfaac91ea00efea505 (patch)
treecafaf1bdf217c8e6eecf4c9e5bffff91cc2ed46f /configure.ac
parent7e45a7f7a562692348f27e4587e2422ecbb11b38 (diff)
downloaddimension-20a55aa78050d94b187d4edfaac91ea00efea505.tar.xz
Revert "Add support for jemalloc."
This reverts commit bac926b1e54696beee1d84834876cfadd9939132. Just use LD_PRELOAD if you want it.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 0 insertions, 13 deletions
diff --git a/configure.ac b/configure.ac
index bbb881c..0170fa0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -37,19 +37,6 @@ AC_PROG_LN_S
AC_PROG_MAKE_SET
AC_PROG_LIBTOOL
-dnl Use jemalloc rather than the default malloc implementation
-AC_ARG_ENABLE([jemalloc],
- [AS_HELP_STRING([--enable-jemalloc],
- [Enable the jemalloc allocator [default=check]])],
- [],
- [enable_jemalloc=check])
-if test "$enable_jemalloc" = "check"; then
- AC_CHECK_LIB([jemalloc], [malloc],
- [enable_jemalloc=yes],
- [enable_jemalloc=no])
-fi
-AM_CONDITIONAL([JEMALLOC], [test "$enable_jemalloc" != "no"])
-
dnl PNG canvas export
AC_ARG_ENABLE([png],
[AS_HELP_STRING([--enable-png],