summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorTavian Barnes <tavianator@gmail.com>2010-11-11 21:00:32 -0500
committerTavian Barnes <tavianator@gmail.com>2010-11-11 21:00:32 -0500
commit7e45a7f7a562692348f27e4587e2422ecbb11b38 (patch)
tree37774d3d0a6e788fbb6a623d0782df913b339428 /configure.ac
parentf7f174822cebf5958fc5e6b2a80ba53d0e55a680 (diff)
downloaddimension-7e45a7f7a562692348f27e4587e2422ecbb11b38.tar.xz
Fix configure.ac underquoting.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 8 insertions, 8 deletions
diff --git a/configure.ac b/configure.ac
index 4196c32..bbb881c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -84,7 +84,7 @@ AC_SUBST(libsandglass_LIBS)
dnl Platform feature tests
AC_MSG_CHECKING([for sched_getaffinity()])
-AC_LINK_IFELSE(
+AC_LINK_IFELSE([
AC_LANG_PROGRAM(
[
#define _GNU_SOURCE
@@ -94,7 +94,7 @@ AC_LINK_IFELSE(
cpu_set_t cpuset;
sched_getaffinity(0, sizeof(cpuset), &cpuset);
]
- ),
+ )],
[AC_DEFINE([DMNSN_SCHED_GETAFFINITY], [1])
AC_MSG_RESULT([yes])],
[AC_DEFINE([DMNSN_SCHED_GETAFFINITY], [0])
@@ -102,11 +102,11 @@ AC_LINK_IFELSE(
)
AC_MSG_CHECKING([for sysconf(_SC_NPROCESSORS_ONLN)])
-AC_COMPILE_IFELSE(
+AC_COMPILE_IFELSE([
AC_LANG_PROGRAM(
[ #include <unistd.h> ],
[ sysconf(_SC_NPROCESSORS_ONLN); ]
- ),
+ )],
[AC_DEFINE([DMNSN_SC_NPROCESSORS_ONLN], [1])
AC_MSG_RESULT([yes])],
[AC_DEFINE([DMNSN_SC_NPROCESSORS_ONLN], [0])
@@ -114,11 +114,11 @@ AC_COMPILE_IFELSE(
)
AC_MSG_CHECKING([for backtrace()])
-AC_LINK_IFELSE(
+AC_LINK_IFELSE([
AC_LANG_PROGRAM(
[ #include <execinfo.h> ],
[ backtrace(0, 0); ]
- ),
+ )],
[AC_DEFINE([DMNSN_BACKTRACE], [1])
AC_MSG_RESULT([yes])],
[AC_DEFINE([DMNSN_BACKTRACE], [0])
@@ -126,11 +126,11 @@ AC_LINK_IFELSE(
)
AC_MSG_CHECKING([for gettid()])
-AC_COMPILE_IFELSE(
+AC_COMPILE_IFELSE([
AC_LANG_PROGRAM(
[ #include <sys/syscall.h> ],
[ syscall(SYS_gettid); ]
- ),
+ )],
[AC_DEFINE([DMNSN_GETTID], [1])
AC_MSG_RESULT([yes])],
[AC_DEFINE([DMNSN_GETTID], [0])