summaryrefslogtreecommitdiffstats
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorTavian Barnes <tavianator@gmail.com>2009-09-17 03:18:42 +0000
committerTavian Barnes <tavianator@gmail.com>2009-09-17 03:18:42 +0000
commitf46ea7eb1b6f55036f10b6ae919c1785cb72c836 (patch)
tree363720df95e7f462ff677b9c3515f47c842dc186 /tests/Makefile.am
parentfb147c5f6570a971ae25d07c74f94f6d2fdcb130 (diff)
downloadlibsandglass-f46ea7eb1b6f55036f10b6ae919c1785cb72c836.tar.xz
Add test suite.
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am26
1 files changed, 26 insertions, 0 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
new file mode 100644
index 0000000..b42882e
--- /dev/null
+++ b/tests/Makefile.am
@@ -0,0 +1,26 @@
+###########################################################################
+## Copyright (C) 2009 Tavian Barnes <tavianator@gmail.com> ##
+## ##
+## This file is part of The Dimension Build Suite. ##
+## ##
+## The Dimension Build Suite is free software; you can redistribute it ##
+## and/or modify it under the terms of the GNU General Public License as ##
+## published by the Free Software Foundation; either version 3 of the ##
+## License, or (at your option) any later version. ##
+## ##
+## The Dimension Build Suite is distributed in the hope that it will be ##
+## useful, but WITHOUT ANY WARRANTY; without even the implied warranty ##
+## of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU ##
+## General Public License for more details. ##
+## ##
+## You should have received a copy of the GNU General Public License ##
+## along with this program. If not, see <http://www.gnu.org/licenses/>. ##
+###########################################################################
+
+check_PROGRAMS = simple-test
+TESTS = $(check_PROGRAMS)
+
+INCLUDES = -I../src
+
+simple_test_SOURCES = simple.c
+simple_test_LDADD = ../src/libsandglass.la