summaryrefslogtreecommitdiffstats
path: root/libdimensionxx/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'libdimensionxx/Makefile.am')
-rw-r--r--libdimensionxx/Makefile.am26
1 files changed, 26 insertions, 0 deletions
diff --git a/libdimensionxx/Makefile.am b/libdimensionxx/Makefile.am
new file mode 100644
index 0000000..60608e4
--- /dev/null
+++ b/libdimensionxx/Makefile.am
@@ -0,0 +1,26 @@
+###########################################################################
+## Copyright (C) 2008 Tavian Barnes <tavianator@gmail.com> ##
+## ##
+## This file is part of The Dimension Build Suite. ##
+## ##
+## The Dimension Build Suite is free software; you can redistribute it ##
+## and/or modify it under the terms of the GNU General Public License as ##
+## published by the Free Software Foundation; either version 3 of the ##
+## License, or (at your option) any later version. ##
+## ##
+## The Dimension Build Suite is distributed in the hope that it will be ##
+## useful, but WITHOUT ANY WARRANTY; without even the implied warranty ##
+## of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU ##
+## General Public License for more details. ##
+## ##
+## You should have received a copy of the GNU General Public License ##
+## along with this program. If not, see <http://www.gnu.org/licenses/>. ##
+###########################################################################
+
+nobase_include_HEADERS = dimensionxx.hpp dimensionxx/geometry.hpp dimensionxx/color.hpp dimensionxx/canvas.hpp
+
+lib_LTLIBRARIES = libdimensionxx.la
+
+libdimensionxx_la_SOURCES = dimensionxx.hpp dimensionxx/geometry.hpp dimensionxx/color.hpp dimensionxx/canvas.hpp canvas.cpp color.cpp geometry.cpp
+libdimensionxx_la_LDFLAGS = -version-info 0:0:0
+libdimensionxx_la_LIBADD = ../libdimension/libdimension.la ../libdimension-png/libdimension-png.la