summaryrefslogtreecommitdiffstats
path: root/dimension/tests/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'dimension/tests/Makefile.am')
-rw-r--r--dimension/tests/Makefile.am30
1 files changed, 30 insertions, 0 deletions
diff --git a/dimension/tests/Makefile.am b/dimension/tests/Makefile.am
new file mode 100644
index 0000000..147df24
--- /dev/null
+++ b/dimension/tests/Makefile.am
@@ -0,0 +1,30 @@
+###########################################################################
+## Copyright (C) 2009-2011 Tavian Barnes <tavianator@tavianator.com> ##
+## ##
+## This file is part of The Dimension Build Suite. ##
+## ##
+## The Dimension Build Suite is free software; you can redistribute it ##
+## and/or modify it under the terms of the GNU General Public License as ##
+## published by the Free Software Foundation; either version 3 of the ##
+## License, or (at your option) any later version. ##
+## ##
+## The Dimension Build Suite is distributed in the hope that it will be ##
+## useful, but WITHOUT ANY WARRANTY; without even the implied warranty ##
+## of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU ##
+## General Public License for more details. ##
+## ##
+## You should have received a copy of the GNU General Public License ##
+## along with this program. If not, see <http://www.gnu.org/licenses/>. ##
+###########################################################################
+
+TESTS = demo.dmnsn \
+ complex.dmnsn
+TEST_EXTENSIONS = .dmnsn
+DMNSN_LOG_COMPILER = $(top_builddir)/dimension/dimension
+AM_DMNSN_LOG_FLAGS = --strict
+TESTS_ENVIRONMENT = PYTHONPATH=$(top_builddir)/libdimension-python/.libs
+
+EXTRA_DIST = $(TESTS)
+
+clean-local:
+ rm -f *.png