summaryrefslogtreecommitdiffstats
path: root/tests/libdimension/Makefile.am
diff options
context:
space:
mode:
authorTavian Barnes <tavianator@gmail.com>2011-02-28 16:28:21 -0500
committerTavian Barnes <tavianator@gmail.com>2011-03-08 21:43:18 -0500
commita2bf45329a172d2c53594c64d27f1c15ac26796a (patch)
tree93c6c3e7404e4abc605c410f978aefa3dd3231fa /tests/libdimension/Makefile.am
parentf69c955c28b7e5c2eaf4af036cb88480a8e433f3 (diff)
downloaddimension-a2bf45329a172d2c53594c64d27f1c15ac26796a.tar.xz
New dmnsn_warning() API, remove different severities.
Diffstat (limited to 'tests/libdimension/Makefile.am')
-rw-r--r--tests/libdimension/Makefile.am16
1 files changed, 10 insertions, 6 deletions
diff --git a/tests/libdimension/Makefile.am b/tests/libdimension/Makefile.am
index 718056e..8a53bcf 100644
--- a/tests/libdimension/Makefile.am
+++ b/tests/libdimension/Makefile.am
@@ -20,8 +20,9 @@
INCLUDES = -I$(top_srcdir)/libdimension
check_LTLIBRARIES = libdimension-tests.la
-check_PROGRAMS = error-test \
- warning-test \
+check_PROGRAMS = warning-test \
+ warning-as-error-test \
+ error-test \
list-test \
polynomial-test \
prtree-test \
@@ -30,7 +31,7 @@ check_PROGRAMS = error-test \
render-test \
cxx-test
TESTS = $(check_PROGRAMS)
-XFAIL_TESTS = error-test
+XFAIL_TESTS = warning-as-error-test error-test
if !PNG
XFAIL_TESTS += png-test
@@ -50,12 +51,15 @@ else
libdimension_tests_la_SOURCES += display-stubs.c
endif
-error_test_SOURCES = error.c
-error_test_LDADD = libdimension-tests.la
-
warning_test_SOURCES = warning.c
warning_test_LDADD = libdimension-tests.la
+warning_as_error_test_SOURCES = warning-as-error.c
+warning_as_error_test_LDADD = libdimension-tests.la
+
+error_test_SOURCES = error.c
+error_test_LDADD = libdimension-tests.la
+
list_test_SOURCES = list.c
list_test_LDADD = libdimension-tests.la