summaryrefslogtreecommitdiffstats
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorTavian Barnes <tavianator@gmail.com>2009-09-11 18:01:51 +0000
committerTavian Barnes <tavianator@gmail.com>2009-09-11 18:01:51 +0000
commite2c5e2760d98144ac65c4c9f15e7675ec7852319 (patch)
treee3564072ffef9499e30b8ef2803fb5d4005ad7a8 /tests/Makefile.am
parent29de9f06dbfeae9006aa711d3aa2ef785e622eef (diff)
downloaddimension-e2c5e2760d98144ac65c4c9f15e7675ec7852319.tar.xz
Only test C++ interface - the C library is used by libdimensionxx
anyway, so we've been testing it twice for no good reason.
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am32
1 files changed, 9 insertions, 23 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index f4c4107..e26b181 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -17,42 +17,28 @@
## along with this program. If not, see <http://www.gnu.org/licenses/>. ##
###########################################################################
-check_LTLIBRARIES = libdimension-tests.la \
- libdimensionxx-tests.la
+check_LTLIBRARIES = libdimension-tests.la
check_PROGRAMS = warning-test \
error-test \
png-test \
- pngxx-test \
- gl-test \
- glxx-test
+ gl-test
TESTS = $(check_PROGRAMS)
XFAIL_TESTS = error-test
INCLUDES = -I../libdimension -I../libdimensionxx
-libdimension_tests_la_SOURCES = tests.h \
- tests.c
-libdimension_tests_la_LIBADD = ../libdimension/libdimension.la
+libdimension_tests_la_SOURCES = tests.hpp \
+ tests.cpp
+libdimension_tests_la_LIBADD = ../libdimensionxx/libdimensionxx.la
-libdimensionxx_tests_la_SOURCES = testsxx.hpp \
- testsxx.cpp
-libdimensionxx_tests_la_LIBADD = ./libdimension-tests.la \
- ../libdimensionxx/libdimensionxx.la
-
-warning_test_SOURCES = warning.c
+warning_test_SOURCES = warning.cpp
warning_test_LDADD = ./libdimension-tests.la
-error_test_SOURCES = error.c
+error_test_SOURCES = error.cpp
error_test_LDADD = ./libdimension-tests.la
-png_test_SOURCES = png.c
+png_test_SOURCES = png.cpp
png_test_LDADD = ./libdimension-tests.la
-pngxx_test_SOURCES = pngxx.cpp
-pngxx_test_LDADD = ./libdimensionxx-tests.la
-
-gl_test_SOURCES = gl.c
+gl_test_SOURCES = gl.cpp
gl_test_LDADD = ./libdimension-tests.la
-
-glxx_test_SOURCES = glxx.cpp
-glxx_test_LDADD = ./libdimensionxx-tests.la