summaryrefslogtreecommitdiffstats
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorTavian Barnes <tavianator@gmail.com>2009-04-10 05:23:32 +0000
committerTavian Barnes <tavianator@gmail.com>2009-04-10 05:23:32 +0000
commit27c8c600022b64aad0737a46bc67c27838ae2424 (patch)
treebfa3a1a189ceafee6ae751abb557880e49602afd /tests/Makefile.am
parent968e1d8710004517639966bd4c6f83f37edccd21 (diff)
downloaddimension-27c8c600022b64aad0737a46bc67c27838ae2424.tar.xz
New tests for error framework.
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am25
1 files changed, 16 insertions, 9 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index d596017..9c9c4ed 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -1,26 +1,33 @@
###########################################################################
## Copyright (C) 2008 Tavian Barnes <tavianator@gmail.com> ##
## ##
-## This file is part of The FPFD Library Build Suite. ##
+## This file is part of the Dimension Build Suite. ##
## ##
-## The FPFD Library Build Suite is free software; you can redistribute ##
-## it and/or modify it under the terms of the GNU General Public License ##
-## as published by the Free Software Foundation; either version 3 of the ##
+## The Dimension Build Suite is free software; you can redistribute it ##
+## and/or modify it under the terms of the GNU General Public License as ##
+## published by the Free Software Foundation; either version 3 of the ##
## License, or (at your option) any later version. ##
## ##
-## The FPFD Library Build Suite is distributed in the hope that it will ##
-## be useful, but WITHOUT ANY WARRANTY; without even the implied ##
-## warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See ##
-## the GNU General Public License for more details. ##
+## The Dimension Build Suite is distributed in the hope that it will be ##
+## useful, but WITHOUT ANY WARRANTY; without even the implied warranty ##
+## of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU ##
+## General Public License for more details. ##
## ##
## You should have received a copy of the GNU General Public License ##
## along with this program. If not, see <http://www.gnu.org/licenses/>. ##
###########################################################################
-check_PROGRAMS = png
+check_PROGRAMS = warning error png
TESTS = $(check_PROGRAMS)
+XFAIL_TESTS = error
INCLUDES = -I../libdimension -I../libdimension-png
+warning_SOURCES = warning.c
+warning_LDADD = ../libdimension/libdimension.la
+
+error_SOURCES = error.c
+error_LDADD = ../libdimension/libdimension.la
+
png_SOURCES = png.c
png_LDADD = ../libdimension/libdimension.la ../libdimension-png/libdimension-png.la