summaryrefslogtreecommitdiffstats
path: root/libdimension/tests/Makefile.am
diff options
context:
space:
mode:
authorTavian Barnes <tavianator@gmail.com>2011-05-15 15:54:56 -0600
committerTavian Barnes <tavianator@gmail.com>2011-05-15 15:58:05 -0600
commita5a6b94c038e01ebf1e2de0a0774a69b02fb8e1e (patch)
tree66a4b977fff9f0119456b6c5a3398d25976f6c53 /libdimension/tests/Makefile.am
parent130cbc32499ade9235873bc5d575816f80636916 (diff)
downloaddimension-a5a6b94c038e01ebf1e2de0a0774a69b02fb8e1e.tar.xz
Group tests and benchmarks with the corresponding source code.
Diffstat (limited to 'libdimension/tests/Makefile.am')
-rw-r--r--libdimension/tests/Makefile.am81
1 files changed, 81 insertions, 0 deletions
diff --git a/libdimension/tests/Makefile.am b/libdimension/tests/Makefile.am
new file mode 100644
index 0000000..6b5f8ca
--- /dev/null
+++ b/libdimension/tests/Makefile.am
@@ -0,0 +1,81 @@
+###########################################################################
+## Copyright (C) 2009-2011 Tavian Barnes <tavianator@tavianator.com> ##
+## ##
+## This file is part of The Dimension Build Suite. ##
+## ##
+## The Dimension Build Suite is free software; you can redistribute it ##
+## and/or modify it under the terms of the GNU General Public License as ##
+## published by the Free Software Foundation; either version 3 of the ##
+## License, or (at your option) any later version. ##
+## ##
+## The Dimension Build Suite is distributed in the hope that it will be ##
+## useful, but WITHOUT ANY WARRANTY; without even the implied warranty ##
+## of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU ##
+## General Public License for more details. ##
+## ##
+## You should have received a copy of the GNU General Public License ##
+## along with this program. If not, see <http://www.gnu.org/licenses/>. ##
+###########################################################################
+
+INCLUDES = -I$(top_srcdir)/libdimension
+
+check_LTLIBRARIES = libdimension-tests.la
+check_PROGRAMS = warning-test \
+ warning-as-error-test \
+ error-test \
+ polynomial-test \
+ prtree-test \
+ png-test \
+ gl-test \
+ render-test \
+ cxx-test
+TESTS = $(check_PROGRAMS)
+XFAIL_TESTS = warning-as-error-test error-test
+
+if !PNG
+XFAIL_TESTS += png-test
+endif
+
+if !GL
+XFAIL_TESTS += gl-test
+endif
+
+libdimension_tests_la_SOURCES = tests.h
+libdimension_tests_la_LIBADD = $(top_builddir)/libdimension/libdimension.la
+
+if GLX
+libdimension_tests_la_SOURCES += display.c
+libdimension_tests_la_LIBADD += -lX11 -lGL
+else
+libdimension_tests_la_SOURCES += display-stubs.c
+endif
+
+warning_test_SOURCES = warning.c
+warning_test_LDADD = libdimension-tests.la
+
+warning_as_error_test_SOURCES = warning-as-error.c
+warning_as_error_test_LDADD = libdimension-tests.la
+
+error_test_SOURCES = error.c
+error_test_LDADD = libdimension-tests.la
+
+polynomial_test_SOURCES = polynomial.c
+polynomial_test_LDADD = libdimension-tests.la
+
+prtree_test_SOURCES = prtree.c
+prtree_test_LDADD = libdimension-tests.la
+
+png_test_SOURCES = png.c
+png_test_LDADD = libdimension-tests.la
+
+gl_test_SOURCES = gl.c
+gl_test_LDADD = libdimension-tests.la
+
+render_test_SOURCES = render.c
+render_test_LDADD = libdimension-tests.la
+
+cxx_test_SOURCES = cxx.cpp
+cxx_test_LDADD = libdimension-tests.la
+
+clean-local:
+ rm -f *.png