summaryrefslogtreecommitdiffstats
path: root/libdimension/bench/Makefile.am
diff options
context:
space:
mode:
authorTavian Barnes <tavianator@tavianator.com>2013-03-19 19:41:59 -0400
committerTavian Barnes <tavianator@tavianator.com>2013-03-19 19:51:33 -0400
commite597ca66bebb5ef62d3aac6ee832e5ccc811454d (patch)
treebcb47b26b233e6ef45c81b2e5b46ff6eb90a5c24 /libdimension/bench/Makefile.am
parenta0a11f34d75eef9971a870fd51dd6d08f7708311 (diff)
downloaddimension-e597ca66bebb5ef62d3aac6ee832e5ccc811454d.tar.xz
Add a benchmark for dmnsn_future.
Diffstat (limited to 'libdimension/bench/Makefile.am')
-rw-r--r--libdimension/bench/Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/libdimension/bench/Makefile.am b/libdimension/bench/Makefile.am
index 09530ff..934657c 100644
--- a/libdimension/bench/Makefile.am
+++ b/libdimension/bench/Makefile.am
@@ -1,5 +1,5 @@
###########################################################################
-## Copyright (C) 2009-2011 Tavian Barnes <tavianator@tavianator.com> ##
+## Copyright (C) 2009-2013 Tavian Barnes <tavianator@tavianator.com> ##
## ##
## This file is part of The Dimension Build Suite. ##
## ##
@@ -20,6 +20,7 @@
EXTRA_PROGRAMS = array.bench \
geometry.bench \
polynomial.bench \
+ future.bench \
prtree.bench
AM_CFLAGS = $(libsandglass_CFLAGS) -fno-inline -I$(top_srcdir)/libdimension
@@ -28,6 +29,7 @@ AM_LDFLAGS = $(libsandglass_LIBS) $(top_builddir)/libdimension/libdimension.la
array_bench_SOURCES = array.c
geometry_bench_SOURCES = geometry.c
polynomial_bench_SOURCES = polynomial.c
+future_bench_SOURCES = future.c
prtree_bench_SOURCES = prtree.c
prtree_bench_CFLAGS = $(AM_CFLAGS) -finline
@@ -35,6 +37,7 @@ bench: $(EXTRA_PROGRAMS)
./array.bench
./geometry.bench
./polynomial.bench
+ ./future.bench
./prtree.bench
clean-local: