summaryrefslogtreecommitdiffstats
path: root/libdimension/bench/Makefile.am
diff options
context:
space:
mode:
authorTavian Barnes <tavianator@gmail.com>2011-05-15 15:54:56 -0600
committerTavian Barnes <tavianator@gmail.com>2011-05-15 15:58:05 -0600
commita5a6b94c038e01ebf1e2de0a0774a69b02fb8e1e (patch)
tree66a4b977fff9f0119456b6c5a3398d25976f6c53 /libdimension/bench/Makefile.am
parent130cbc32499ade9235873bc5d575816f80636916 (diff)
downloaddimension-a5a6b94c038e01ebf1e2de0a0774a69b02fb8e1e.tar.xz
Group tests and benchmarks with the corresponding source code.
Diffstat (limited to 'libdimension/bench/Makefile.am')
-rw-r--r--libdimension/bench/Makefile.am41
1 files changed, 41 insertions, 0 deletions
diff --git a/libdimension/bench/Makefile.am b/libdimension/bench/Makefile.am
new file mode 100644
index 0000000..353acb3
--- /dev/null
+++ b/libdimension/bench/Makefile.am
@@ -0,0 +1,41 @@
+###########################################################################
+## Copyright (C) 2009-2010 Tavian Barnes <tavianator@tavianator.com> ##
+## ##
+## This file is part of The Dimension Build Suite. ##
+## ##
+## The Dimension Build Suite is free software; you can redistribute it ##
+## and/or modify it under the terms of the GNU General Public License as ##
+## published by the Free Software Foundation; either version 3 of the ##
+## License, or (at your option) any later version. ##
+## ##
+## The Dimension Build Suite is distributed in the hope that it will be ##
+## useful, but WITHOUT ANY WARRANTY; without even the implied warranty ##
+## of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU ##
+## General Public License for more details. ##
+## ##
+## You should have received a copy of the GNU General Public License ##
+## along with this program. If not, see <http://www.gnu.org/licenses/>. ##
+###########################################################################
+
+INCLUDES = -I$(top_srcdir)/libdimension
+
+EXTRA_PROGRAMS = bench-array \
+ bench-geometry \
+ bench-polynomial \
+ bench-prtree
+
+AM_CFLAGS = $(libsandglass_CFLAGS) -fno-inline
+AM_LDFLAGS = $(libsandglass_LIBS) $(top_builddir)/libdimension/libdimension.la
+
+bench_array_SOURCES = array.c
+bench_geometry_SOURCES = geometry.c
+bench_polynomial_SOURCES = polynomial.c
+bench_prtree_SOURCES = prtree.c
+
+bench: $(EXTRA_PROGRAMS)
+ ./bench-array
+ ./bench-geometry
+ ./bench-polynomial
+ ./bench-prtree
+
+.PHONY: bench