summaryrefslogtreecommitdiffstats
path: root/libdimension/bench/Makefile.am
diff options
context:
space:
mode:
authorTavian Barnes <tavianator@tavianator.com>2014-05-22 18:15:50 -0400
committerTavian Barnes <tavianator@tavianator.com>2014-05-22 18:15:50 -0400
commit95acde693f9d217b9a035585cd9087042503727e (patch)
tree6d34b8c99a2c41a719650932f6ae176e5d1df79b /libdimension/bench/Makefile.am
parent4a5ba266d41428158bf1b65d2976c11126174996 (diff)
downloaddimension-95acde693f9d217b9a035585cd9087042503727e.tar.xz
bench: Add a triangle intersection benchmark.
Diffstat (limited to 'libdimension/bench/Makefile.am')
-rw-r--r--libdimension/bench/Makefile.am7
1 files changed, 5 insertions, 2 deletions
diff --git a/libdimension/bench/Makefile.am b/libdimension/bench/Makefile.am
index 934657c..51e2f30 100644
--- a/libdimension/bench/Makefile.am
+++ b/libdimension/bench/Makefile.am
@@ -1,5 +1,5 @@
###########################################################################
-## Copyright (C) 2009-2013 Tavian Barnes <tavianator@tavianator.com> ##
+## Copyright (C) 2009-2014 Tavian Barnes <tavianator@tavianator.com> ##
## ##
## This file is part of The Dimension Build Suite. ##
## ##
@@ -21,7 +21,8 @@ EXTRA_PROGRAMS = array.bench \
geometry.bench \
polynomial.bench \
future.bench \
- prtree.bench
+ prtree.bench \
+ triangle.bench
AM_CFLAGS = $(libsandglass_CFLAGS) -fno-inline -I$(top_srcdir)/libdimension
AM_LDFLAGS = $(libsandglass_LIBS) $(top_builddir)/libdimension/libdimension.la
@@ -32,6 +33,7 @@ polynomial_bench_SOURCES = polynomial.c
future_bench_SOURCES = future.c
prtree_bench_SOURCES = prtree.c
prtree_bench_CFLAGS = $(AM_CFLAGS) -finline
+triangle_bench_SOURCES = triangle.c
bench: $(EXTRA_PROGRAMS)
./array.bench
@@ -39,6 +41,7 @@ bench: $(EXTRA_PROGRAMS)
./polynomial.bench
./future.bench
./prtree.bench
+ ./triangle.bench
clean-local:
rm -f *.bench