summaryrefslogtreecommitdiffstats
path: root/libdimension/Makefile.am
diff options
context:
space:
mode:
authorTavian Barnes <tavianator@gmail.com>2011-12-14 19:27:22 -0500
committerTavian Barnes <tavianator@gmail.com>2011-12-14 19:52:36 -0500
commitbfbe9e43e108f6816c17b9b7764b75284ac78313 (patch)
tree189f85eeec18a76ccb626e45455fa7e45406db7c /libdimension/Makefile.am
parent7db5342a36341b061a8785a3b349cf0fcad69ebf (diff)
downloaddimension-bfbe9e43e108f6816c17b9b7764b75284ac78313.tar.xz
Re-think colors.
Color is a property of light, and thus doesn't include information about transparency. But canvas pixels and object pigments represent a color and a degree of transparency. The new type dmnsn_tcolor/ TColor encapsulates that information. Also, fix the transparent shadow implementation.
Diffstat (limited to 'libdimension/Makefile.am')
-rw-r--r--libdimension/Makefile.am2
1 files changed, 0 insertions, 2 deletions
diff --git a/libdimension/Makefile.am b/libdimension/Makefile.am
index e99fe3c..aa5921e 100644
--- a/libdimension/Makefile.am
+++ b/libdimension/Makefile.am
@@ -63,12 +63,10 @@ nobase_include_HEADERS = dimension.h \
lib_LTLIBRARIES = libdimension.la
libdimension_la_SOURCES = $(nobase_include_HEADERS) \
- ambient.c \
camera.c \
canvas.c \
canvas_pigment.c \
checker.c \
- color.c \
compiler-internal.h \
cone.c \
cube.c \