summaryrefslogtreecommitdiffstats
path: root/libdimension/Makefile.am
diff options
context:
space:
mode:
authorTavian Barnes <tavianator@gmail.com>2010-04-07 14:26:15 -0400
committerTavian Barnes <tavianator@gmail.com>2010-04-07 14:34:52 -0400
commit2b087cb45ae91f90492a935625570d7d42ee3ecb (patch)
treea464213b08d04c8c91c8879a84e534f895c84378 /libdimension/Makefile.am
parent7d6663eeb68bf9d0a3dff86128827c0c1d85df69 (diff)
downloaddimension-2b087cb45ae91f90492a935625570d7d42ee3ecb.tar.xz
New dmnsn_malloc() function, and friends.
I'm tired of checking for malloc failures everywhere, considering it never happens. So just bail out whenever it does. A lot of stuff is guaranteed to succeed if it returns now.
Diffstat (limited to 'libdimension/Makefile.am')
-rw-r--r--libdimension/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/libdimension/Makefile.am b/libdimension/Makefile.am
index 2dda68c..9774202 100644
--- a/libdimension/Makefile.am
+++ b/libdimension/Makefile.am
@@ -34,6 +34,7 @@ nobase_include_HEADERS = dimension.h \
dimension/interior.h \
dimension/light.h \
dimension/lights.h \
+ dimension/malloc.h \
dimension/object.h \
dimension/objects.h \
dimension/pigments.h \
@@ -62,6 +63,7 @@ libdimension_la_SOURCES = $(nobase_include_HEADERS) \
inlines.c \
interior.c \
light.c \
+ malloc.c \
object.c \
perspective.c \
phong.c \