summaryrefslogtreecommitdiffstats
path: root/libdimension-python/Makefile.am
diff options
context:
space:
mode:
authorTavian Barnes <tavianator@gmail.com>2011-05-16 08:07:27 -0600
committerTavian Barnes <tavianator@gmail.com>2011-05-16 08:07:27 -0600
commit87bc3cb4fcaf0e3ead4c41e8c56a06cf481875c0 (patch)
tree21d197a48775d0aefa4be66c28986c24740506e4 /libdimension-python/Makefile.am
parent811e883fd115dce835aa89999d6f8b85752e80da (diff)
downloaddimension-87bc3cb4fcaf0e3ead4c41e8c56a06cf481875c0.tar.xz
Start Python interface.
Diffstat (limited to 'libdimension-python/Makefile.am')
-rw-r--r--libdimension-python/Makefile.am27
1 files changed, 27 insertions, 0 deletions
diff --git a/libdimension-python/Makefile.am b/libdimension-python/Makefile.am
new file mode 100644
index 0000000..a362964
--- /dev/null
+++ b/libdimension-python/Makefile.am
@@ -0,0 +1,27 @@
+###########################################################################
+## Copyright (C) 2009-2011 Tavian Barnes <tavianator@tavianator.com> ##
+## ##
+## This file is part of The Dimension Build Suite. ##
+## ##
+## The Dimension Build Suite is free software; you can redistribute it ##
+## and/or modify it under the terms of the GNU General Public License as ##
+## published by the Free Software Foundation; either version 3 of the ##
+## License, or (at your option) any later version. ##
+## ##
+## The Dimension Build Suite is distributed in the hope that it will be ##
+## useful, but WITHOUT ANY WARRANTY; without even the implied warranty ##
+## of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU ##
+## General Public License for more details. ##
+## ##
+## You should have received a copy of the GNU General Public License ##
+## along with this program. If not, see <http://www.gnu.org/licenses/>. ##
+###########################################################################
+
+INCLUDES = -I$(top_srcdir)/libdimension
+
+AM_CFLAGS = $(Python_CFLAGS)
+AM_LDFLAGS = $(Python_LDFLAGS)
+
+pyexec_LTLIBRARIES = dimension.la
+dimension_la_SOURCES = dimension.c
+dimension_la_LDFLAGS = -avoid-version -module