summaryrefslogtreecommitdiffstats
path: root/libdimension-python/Makefile.am
diff options
context:
space:
mode:
authorTavian Barnes <tavianator@gmail.com>2011-05-22 14:22:07 -0600
committerTavian Barnes <tavianator@gmail.com>2011-05-22 14:22:07 -0600
commit1bf306d4d93cc21c220a3f31835023e49e84dd2d (patch)
tree436959a8321100a3c36e8eef9a19279cb446e1fa /libdimension-python/Makefile.am
parent0f0b704144bddc045657f7ed852b49d5e349b0bd (diff)
downloaddimension-1bf306d4d93cc21c220a3f31835023e49e84dd2d.tar.xz
Add cameras, objects, and spheres to Python module.
Diffstat (limited to 'libdimension-python/Makefile.am')
-rw-r--r--libdimension-python/Makefile.am10
1 files changed, 9 insertions, 1 deletions
diff --git a/libdimension-python/Makefile.am b/libdimension-python/Makefile.am
index e2d2049..9919a1a 100644
--- a/libdimension-python/Makefile.am
+++ b/libdimension-python/Makefile.am
@@ -26,14 +26,22 @@ AM_CFLAGS = $(Python_CFLAGS)
AM_LDFLAGS = $(Python_LDFLAGS)
pyexec_LTLIBRARIES = dimension.la
-dimension_la_SOURCES = Canvas.c \
+dimension_la_SOURCES = Camera.c \
+ Camera.h \
+ Canvas.c \
Canvas.h \
Color.c \
Color.h \
Matrix.c \
Matrix.h \
+ Object.c \
+ Object.h \
+ PerspectiveCamera.c \
+ PerspectiveCamera.h \
Scene.c \
Scene.h \
+ Sphere.c \
+ Sphere.h \
Vector.c \
Vector.h \
dimension.c \