summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorTavian Barnes <tavianator@gmail.com>2009-03-01 01:25:13 +0000
committerTavian Barnes <tavianator@gmail.com>2009-03-01 01:25:13 +0000
commitef4dbe789201bcb92596a67eb3fb3f3f03a09b49 (patch)
treed1591af1f8d50139c2eb154cca7b2fb9b0307785 /configure.ac
parentc7d93bfa183df3a22552c33c0af1dfc7658269ec (diff)
downloaddimension-ef4dbe789201bcb92596a67eb3fb3f3f03a09b49.tar.xz
Initial commit.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac38
1 files changed, 38 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 0000000..b952b41
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,38 @@
+dnl Copyright (C) 2008 Tavian Barnes <tavianator@gmail.com>
+dnl
+dnl This file is part of the Dimension Build Suite.
+dnl
+dnl The Dimension Build Suite is free software; you can redistribute it
+dnl and/or modify it under the terms of the GNU General Public License as
+dnl published by the Free Software Foundation; either version 3 of the
+dnl License, or (at your option) any later version.
+dnl
+dnl The Dimension Build Suite is distributed in the hope that it will be
+dnl useful, but WITHOUT ANY WARRANTY; without even the implied warranty
+dnl of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+dnl General Public License for more details.
+dnl
+dnl You should have received a copy of the GNU General Public License
+dnl along with this program. If not, see <http://www.gnu.org/licenses/>.
+
+AC_PREREQ(2.63)
+AC_INIT(Dimension, 0.0.0, tavianator@gmail.com, dimension)
+AM_INIT_AUTOMAKE(dimension, 0.0.0)
+
+dnl Programs
+AC_PROG_CC
+AC_PROG_CXX
+AM_PROG_CC_C_O
+AM_PROG_AS
+AC_PROG_INSTALL
+AC_PROG_LN_S
+AC_PROG_MAKE_SET
+AC_PROG_LIBTOOL
+
+dnl Generate Makefiles
+AC_CONFIG_MACRO_DIR([m4])
+AC_CONFIG_FILES([Makefile
+ libdimension/Makefile
+ libdimension-png/Makefile
+ tests/Makefile])
+AC_OUTPUT