summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorTavian Barnes <tavianator@gmail.com>2010-09-26 01:30:54 -0400
committerTavian Barnes <tavianator@gmail.com>2010-09-26 01:30:54 -0400
commitbac926b1e54696beee1d84834876cfadd9939132 (patch)
treeb636cd6e38f37745cd456d5bff01a804b5ac4199 /configure.ac
parent725bd4f0b4cc067fc2770f7f8ffd9c815c745239 (diff)
downloaddimension-bac926b1e54696beee1d84834876cfadd9939132.tar.xz
Add support for jemalloc.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 13 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index e1f127f..4196c32 100644
--- a/configure.ac
+++ b/configure.ac
@@ -37,6 +37,19 @@ AC_PROG_LN_S
AC_PROG_MAKE_SET
AC_PROG_LIBTOOL
+dnl Use jemalloc rather than the default malloc implementation
+AC_ARG_ENABLE([jemalloc],
+ [AS_HELP_STRING([--enable-jemalloc],
+ [Enable the jemalloc allocator [default=check]])],
+ [],
+ [enable_jemalloc=check])
+if test "$enable_jemalloc" = "check"; then
+ AC_CHECK_LIB([jemalloc], [malloc],
+ [enable_jemalloc=yes],
+ [enable_jemalloc=no])
+fi
+AM_CONDITIONAL([JEMALLOC], [test "$enable_jemalloc" != "no"])
+
dnl PNG canvas export
AC_ARG_ENABLE([png],
[AS_HELP_STRING([--enable-png],