summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorTavian Barnes <tavianator@gmail.com>2010-02-23 23:35:36 -0500
committerTavian Barnes <tavianator@gmail.com>2010-02-23 23:35:36 -0500
commitac2890f762db13b35b1f8bd37b0c07855a21c9d8 (patch)
tree4c8efe20f014d341ea36cdcdb2b5a2f1bf7561ea /configure.ac
parent64294f4ac5b1b41e95f20a827c2aead301becb92 (diff)
downloaddimension-ac2890f762db13b35b1f8bd37b0c07855a21c9d8.tar.xz
Use pkg-config for libsandglass.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 6 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index f43dc47..ea454e3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -15,7 +15,7 @@ dnl
dnl You should have received a copy of the GNU General Public License
dnl along with this program. If not, see <http://www.gnu.org/licenses/>.
-AC_PREREQ(2.64)
+AC_PREREQ(2.65)
AC_INIT(Dimension, 0.0.0, tavianator@gmail.com, dimension)
AM_INIT_AUTOMAKE([parallel-tests])
@@ -40,9 +40,11 @@ AC_ARG_ENABLE([pgo],
AM_CONDITIONAL([PGO], [test "$enable_pgo" != "no"])
dnl Timing library for benchmarks
-AC_CHECK_LIB([sandglass], [sandglass_create],
- [],
- [AC_MSG_WARN([libsandglass not found - benchmarking suite will not work])])
+PKG_CHECK_MODULES([SANDGLASS], [libsandglass],
+ [],
+ [AC_MSG_WARN([libsandglass not found - benchmarking suite will not work])])
+AC_SUBST(SANDGLASS_CFLAGS)
+AC_SUBST(SANDGLASS_LIBS)
dnl Ensure compilation in C99 mode
AC_DEFINE([_XOPEN_SOURCE], [600])