summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorTavian Barnes <tavianator@gmail.com>2010-12-01 00:29:34 -0500
committerTavian Barnes <tavianator@gmail.com>2010-12-01 00:30:16 -0500
commit94584e8b20f67a342c625a674590e8bc1aad88cb (patch)
treebd2662ad9b7dd27b1ca405a85bfcebf1097fe8ad /configure.ac
parent950fe8f2b1249369ab0b419b0063e6683bc8080e (diff)
downloaddimension-94584e8b20f67a342c625a674590e8bc1aad88cb.tar.xz
Check for platform support for times().
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac19
1 files changed, 19 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 336c996..6fbf585 100644
--- a/configure.ac
+++ b/configure.ac
@@ -125,6 +125,25 @@ AC_COMPILE_IFELSE([
AC_MSG_RESULT([no])]
)
+AC_MSG_CHECKING([for times()])
+AC_COMPILE_IFELSE([
+ AC_LANG_PROGRAM(
+ [
+ #include <sys/times.h>
+ #include <unistd.h>
+ ],
+ [
+ long clk_tck = sysconf(_SC_CLK_TCK);
+ struct tms buf;
+ clock_t real = times(&buf);
+ ]
+ )],
+ [AC_DEFINE([DMNSN_TIMES], [1])
+ AC_MSG_RESULT([yes])],
+ [AC_DEFINE([DMNSN_TIMES], [0])
+ AC_MSG_RESULT([no])]
+)
+
AC_MSG_CHECKING([for ioctl(TIOCGWINSZ)])
AC_COMPILE_IFELSE([
AC_LANG_PROGRAM(