summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorTavian Barnes <tavianator@gmail.com>2011-01-29 19:14:45 -0500
committerTavian Barnes <tavianator@gmail.com>2011-01-29 19:14:45 -0500
commit9400fce82dcf773c9862006a41681a73b22cbd87 (patch)
tree8193cc766c169c15cf1e74145ea2432ac70286cd /configure.ac
parent4f0c30aee2c56967895c981534414d1b04e9e0ce (diff)
downloaddimension-9400fce82dcf773c9862006a41681a73b22cbd87.tar.xz
Add dmnsn_[un]likely() macros and a profiling framework.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 13 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 75a2deb..8b6e363 100644
--- a/configure.ac
+++ b/configure.ac
@@ -54,6 +54,19 @@ AC_ARG_ENABLE([gl],
[enable_gl=yes])
AM_CONDITIONAL([GL], [test "$enable_gl" != "no"])
+dnl Built-in profiling support
+AC_ARG_ENABLE([profile],
+ [AS_HELP_STRING([--enable-profile],
+ [Enable built-in branch profiling support [default=no]])],
+ [],
+ [enable_profile=no])
+AM_CONDITIONAL([PROFILE], [test "$enable_profile" = "yes"])
+if test "$enable_profile" = "yes"; then
+ AC_DEFINE([DMNSN_PROFILE], [1])
+else
+ AC_DEFINE([DMNSN_PROFILE], [0])
+fi
+
dnl Timing library for benchmarks
PKG_CHECK_MODULES([libsandglass], [libsandglass >= 0.2],
[],