summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorTavian Barnes <tavianator@gmail.com>2011-05-16 08:07:27 -0600
committerTavian Barnes <tavianator@gmail.com>2011-05-16 08:07:27 -0600
commit87bc3cb4fcaf0e3ead4c41e8c56a06cf481875c0 (patch)
tree21d197a48775d0aefa4be66c28986c24740506e4 /configure.ac
parent811e883fd115dce835aa89999d6f8b85752e80da (diff)
downloaddimension-87bc3cb4fcaf0e3ead4c41e8c56a06cf481875c0.tar.xz
Start Python interface.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 11 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index ea1345d..2d566a1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -18,7 +18,7 @@ dnl along with this program. If not, see <http://www.gnu.org/licenses/>.
dnl Initialization
AC_PREREQ(2.65)
AC_INIT(Dimension, 0.0.0, tavianator@tavianator.com, dimension,
- [http://dmnsn.googlecode.com])
+ [http://www.tavianator.com/dimension/])
AM_INIT_AUTOMAKE([parallel-tests color-tests std-options])
AM_SILENT_RULES([yes])
@@ -37,6 +37,7 @@ AC_LIBTOOL_WIN32_DLL
AC_PROG_LN_S
AC_PROG_MAKE_SET
AC_PROG_LIBTOOL
+AM_PATH_PYTHON([3.2])
dnl PNG canvas export
AC_ARG_ENABLE([png],
@@ -62,6 +63,13 @@ AC_ARG_ENABLE([profile],
[enable_profile=no])
AM_CONDITIONAL([PROFILE], [test "$enable_profile" = "yes"])
+dnl Python headers
+PKG_CHECK_MODULES([Python], [python3 >= 3.2],
+ [],
+ [AC_MSG_ERROR([Python not found])])
+AC_SUBST(Python_CFLAGS)
+AC_SUBST(Python_LIBS)
+
dnl Timing library for benchmarks
PKG_CHECK_MODULES([libsandglass], [libsandglass >= 0.2],
[],
@@ -172,5 +180,6 @@ AC_CONFIG_FILES([Makefile
libdimension/Doxyfile
libdimension/bench/Makefile
libdimension/libdimension.pc
- libdimension/tests/Makefile])
+ libdimension/tests/Makefile
+ libdimension-python/Makefile])
AC_OUTPUT