summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorTavian Barnes <tavianator@tavianator.com>2014-06-12 10:23:45 -0400
committerTavian Barnes <tavianator@tavianator.com>2014-06-12 10:27:13 -0400
commit453bb6c1b79d6d4fe4b1277336dc0f4097a5ee6b (patch)
treeb8d4627503708b047230c7148dbceae63100a462 /configure.ac
parent399bc22aff7f1042199cbc425d1df5264d1741af (diff)
downloaddimension-453bb6c1b79d6d4fe4b1277336dc0f4097a5ee6b.tar.xz
Use DMNSN_DEBUG macro instead of NDEBUG.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 4 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index d31a589..4ef71ea 100644
--- a/configure.ac
+++ b/configure.ac
@@ -82,7 +82,10 @@ AC_ARG_ENABLE([debug],
[Perform potentially expensive sanity checks while running [default=no]])],
[],
[enable_debug=no])
-if test "$enable_debug" = "no"; then
+if test "$enable_debug" = "yes"; then
+ AC_DEFINE([DMNSN_DEBUG], [1])
+else
+ AC_DEFINE([DMNSN_DEBUG], [0])
AC_DEFINE([NDEBUG], [1])
fi
AM_CONDITIONAL([DEBUG], [test "$enable_debug" = "yes"])