summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authortavianator <tavianator@antimatter.localdomain>2009-11-19 12:07:17 -0500
committertavianator <tavianator@antimatter.localdomain>2009-11-19 12:07:17 -0500
commite1c53c53d04c8693be00e00804e8e3280dc9dac6 (patch)
tree75682aa77cd04f38d358d556464b6d46223910a3 /Makefile.am
parent4dcb998baf07243838afcb4e202b7fd89399972e (diff)
downloaddimension-e1c53c53d04c8693be00e00804e8e3280dc9dac6.tar.xz
Allow PGO profiling tests to run in parallel.
According to the GCC documentation, -fprofile-arcs handles concurrent executions correctly with file locking.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 9ba1193..a4069dd 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -32,7 +32,7 @@ if PGO
pgo:
@if [ ! -d $(top_builddir)/libdimension/pgo/.libs ] || [ -z "$$(ls $(top_builddir)/libdimension/pgo/.libs/*.gcda 2>/dev/null)" ]; then \
$(MAKE) $(AM_MAKEFLAGS) -C libdimension libdimension-pgo.la && \
- $(MAKE) -j1 -C tests/libdimension check; \
+ $(MAKE) $(AM_MAKEFLAGS) -C tests/libdimension check; \
fi
@rename _pgo_la _la $$(find $(top_builddir)/libdimension/pgo/.libs/)