summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorTavian Barnes <tavianator@gmail.com>2010-01-07 02:55:15 -0500
committerTavian Barnes <tavianator@gmail.com>2010-01-07 02:55:15 -0500
commit9ec20f9888ded5ef9c21f91af26e492c958784b9 (patch)
tree84e7984534dcdf45e38014913a09c41c6e82990a /Makefile.am
parent2cca3158de0fbb40861a06f76bdd5043ac31f046 (diff)
downloaddimension-9ec20f9888ded5ef9c21f91af26e492c958784b9.tar.xz
Make build system more bourne-compatible.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 6 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index a4069dd..1188e78 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -34,7 +34,12 @@ pgo:
$(MAKE) $(AM_MAKEFLAGS) -C libdimension libdimension-pgo.la && \
$(MAKE) $(AM_MAKEFLAGS) -C tests/libdimension check; \
fi
- @rename _pgo_la _la $$(find $(top_builddir)/libdimension/pgo/.libs/)
+ @for pgo in $(top_builddir)/libdimension/pgo/.libs/*; do \
+ replacement="$${pgo/_pgo_la/_la}"; \
+ if [ "$$pgo" != "$$replacement" ]; then \
+ mv "$$pgo" "$$replacement"; \
+ fi \
+ done
all-recursive check-recursive install-recursive installcheck-recursive distdir: pgo