summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorTavian Barnes <tavianator@gmail.com>2009-10-04 19:05:15 +0000
committerTavian Barnes <tavianator@gmail.com>2009-10-04 19:05:15 +0000
commit273761db64335b4dd647f538efbd69a3823c5319 (patch)
treeb1de51bd85fba0d314e84fc2df3cd5a7443c31c8 /Makefile.am
parent2404976a5d1210b4547a76678aada49d0ae74e44 (diff)
downloaddimension-273761db64335b4dd647f538efbd69a3823c5319.tar.xz
New benchmarking suite.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am12
1 files changed, 9 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index 574df64..b474efa 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -18,8 +18,14 @@
###########################################################################
ACLOCAL_AMFLAGS = -I m4
-SUBDIRS = doc \
- libdimension \
- tests
+SUBDIRS = libdimension \
+ tests \
+ bench \
+ doc
EXTRA_DIST = autogen.sh
+
+bench: all-recursive
+ cd bench && $(MAKE) $(AM_MAKEFLAGS) bench
+
+.PHONY: bench