summaryrefslogtreecommitdiffstats
path: root/config/pkgs.mk
diff options
context:
space:
mode:
Diffstat (limited to 'config/pkgs.mk')
-rw-r--r--config/pkgs.mk14
1 files changed, 14 insertions, 0 deletions
diff --git a/config/pkgs.mk b/config/pkgs.mk
new file mode 100644
index 0000000..54024b2
--- /dev/null
+++ b/config/pkgs.mk
@@ -0,0 +1,14 @@
+# Copyright © Tavian Barnes <tavianator@tavianator.com>
+# SPDX-License-Identifier: 0BSD
+
+# Makefile that generates gen/pkgs.mk
+
+.OBJDIR: .
+
+include config/vars.mk
+include ${GEN}/pkgs.mk
+
+default::
+ config/pkgconf.sh --cflags ${PKGS} >>${TARGET} 2>>${TARGET}.log
+ config/pkgconf.sh --ldflags ${PKGS} >>${TARGET} 2>>${TARGET}.log
+ config/pkgconf.sh --ldlibs ${PKGS} >>${TARGET} 2>>${TARGET}.log