summaryrefslogtreecommitdiffstats
path: root/build/pkgs.mk
diff options
context:
space:
mode:
authorTavian Barnes <tavianator@tavianator.com>2024-05-21 15:53:52 -0400
committerTavian Barnes <tavianator@tavianator.com>2024-05-21 15:53:52 -0400
commitdd8e3b8b3e2d55c586e80e62d88719909bd8a568 (patch)
tree2a1de46f9e5b557a90e673e656f531340d0db962 /build/pkgs.mk
parentf9498086969d917a85452560173a0d9db3604c32 (diff)
downloadbfs-dd8e3b8b3e2d55c586e80e62d88719909bd8a568.tar.xz
build: Allow flags.mk to override command line variables
Previously, during something like ./configure LDFLAGS=..., any additions to LDFLAGS from the generated makefiles were ignored. I had thought that sub-make invocations would allow those variables to be overridden, but that is not the behaviour of make. So instead, set _LDFLAGS etc. in the generated files so that they don't conflict.
Diffstat (limited to 'build/pkgs.mk')
-rw-r--r--build/pkgs.mk6
1 files changed, 3 insertions, 3 deletions
diff --git a/build/pkgs.mk b/build/pkgs.mk
index 39b550d..5a26548 100644
--- a/build/pkgs.mk
+++ b/build/pkgs.mk
@@ -15,9 +15,9 @@ gen/pkgs.mk: ${HEADERS}
@printf '# %s\n' "$@" >$@
@gen() { \
printf 'PKGS := %s\n' "$$*"; \
- printf 'CFLAGS += %s\n' "$$(build/pkgconf.sh --cflags "$$@")"; \
- printf 'LDFLAGS += %s\n' "$$(build/pkgconf.sh --ldflags "$$@")"; \
- printf 'LDLIBS := %s $${LDLIBS}\n' "$$(build/pkgconf.sh --ldlibs "$$@")"; \
+ printf '_CFLAGS += %s\n' "$$(build/pkgconf.sh --cflags "$$@")"; \
+ printf '_LDFLAGS += %s\n' "$$(build/pkgconf.sh --ldflags "$$@")"; \
+ printf '_LDLIBS := %s $${_LDLIBS}\n' "$$(build/pkgconf.sh --ldlibs "$$@")"; \
}; \
gen $$(grep -l ' true$$' ${.ALLSRC} | sed 's|.*/\(.*\)\.h|\1|') >>$@
${VCAT} $@