summaryrefslogtreecommitdiffstats
path: root/libdimension-png/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'libdimension-png/Makefile.am')
-rw-r--r--libdimension-png/Makefile.am28
1 files changed, 28 insertions, 0 deletions
diff --git a/libdimension-png/Makefile.am b/libdimension-png/Makefile.am
new file mode 100644
index 0000000..f611ff9
--- /dev/null
+++ b/libdimension-png/Makefile.am
@@ -0,0 +1,28 @@
+###########################################################################
+## Copyright (C) 2008 Tavian Barnes <tavianator@gmail.com> ##
+## ##
+## This file is part of the Dimension Build Suite. ##
+## ##
+## The Dimension Build Suite is free software; you can redistribute it ##
+## and/or modify it under the terms of the GNU General Public License as ##
+## published by the Free Software Foundation; either version 3 of the ##
+## License, or (at your option) any later version. ##
+## ##
+## The Dimension Build Suite is distributed in the hope that it will be ##
+## useful, but WITHOUT ANY WARRANTY; without even the implied warranty ##
+## of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU ##
+## General Public License for more details. ##
+## ##
+## You should have received a copy of the GNU General Public License ##
+## along with this program. If not, see <http://www.gnu.org/licenses/>. ##
+###########################################################################
+
+nobase_include_HEADERS = dimension-png.h
+
+lib_LTLIBRARIES = libdimension-png.la
+
+INCLUDES = -I../libdimension
+
+libdimension_png_la_SOURCES = dimension-png.h png.c
+libdimension_png_la_LDFLAGS = -version-info 0:0:0
+libdimension_png_la_LIBADD = -lpng