summaryrefslogtreecommitdiffstats
path: root/config/pkgs.mk
diff options
context:
space:
mode:
Diffstat (limited to 'config/pkgs.mk')
-rw-r--r--config/pkgs.mk36
1 files changed, 0 insertions, 36 deletions
diff --git a/config/pkgs.mk b/config/pkgs.mk
deleted file mode 100644
index 898f262..0000000
--- a/config/pkgs.mk
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright © Tavian Barnes <tavianator@tavianator.com>
-# SPDX-License-Identifier: 0BSD
-
-# Makefile that generates gen/pkgs.mk
-
-include config/prelude.mk
-include ${GEN}/vars.mk
-include ${GEN}/flags.mk
-include config/exports.mk
-
-HEADERS := ${ALL_PKGS:%=${GEN}/use/%.h}
-
-${GEN}/pkgs.mk: ${HEADERS}
- ${MSG} "[ GEN] ${TGT}"
- printf '# %s\n' "${TGT}" >$@
- gen() { \
- printf 'PKGS := %s\n' "$$*"; \
- printf 'CFLAGS += %s\n' "$$(config/pkgconf.sh --cflags "$$@")"; \
- printf 'LDFLAGS += %s\n' "$$(config/pkgconf.sh --ldflags "$$@")"; \
- printf 'LDLIBS := %s $${LDLIBS}\n' "$$(config/pkgconf.sh --ldlibs "$$@")"; \
- }; \
- gen $$(grep -l ' true$$' ${.ALLSRC} | sed 's|.*/\(.*\)\.h|\1|') >>$@
- ${VCAT} $@
-
-.PHONY: ${GEN}/pkgs.mk
-
-# Convert ${GEN}/use/foo.h to foo
-PKG = ${@:${GEN}/use/%.h=%}
-
-${HEADERS}::
- ${MKDIR} ${@D}
- if config/define-if.sh use/${PKG} config/pkgconf.sh ${PKG} >$@ 2>$@.log; then \
- test "${IS_V}" || printf '[ CC ] %-${MSG_WIDTH}s ✔\n' use/${PKG}.c; \
- else \
- test "${IS_V}" || printf '[ CC ] %-${MSG_WIDTH}s ✘\n' use/${PKG}.c; \
- fi