summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 7 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index deea2b8..c767daa 100644
--- a/configure.ac
+++ b/configure.ac
@@ -41,19 +41,22 @@ AC_CANONICAL_HOST
if echo $host_cpu | grep '86$' 2>&1 >/dev/null
then
- arch_x86="true"
- AC_DEFINE([SANDGLASS_TSC])
+ arch_x86=1
+ tsc=1
fi
if echo $host_cpu | grep 'x86_64$' 2>&1 >/dev/null
then
- arch_x86_64="true"
- AC_DEFINE([SANDGLASS_TSC])
+ arch_x86_64=1
+ tsc=1
fi
AM_CONDITIONAL([X86], [test "$arch_x86"])
AM_CONDITIONAL([X86_64], [test "$arch_x86_64"])
+AC_DEFINE([SANDGLASS_TSC], ["$tsc"])
+AM_CONDITIONAL([TSC], [test "$tsc"])
+
dnl Generate Makefiles
AC_CONFIG_MACRO_DIR([m4])
AC_CONFIG_FILES([Makefile