summaryrefslogtreecommitdiffstats
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorTavian Barnes <tavianator@gmail.com>2009-09-20 01:09:14 +0000
committerTavian Barnes <tavianator@gmail.com>2009-09-20 01:09:14 +0000
commitd69067be2350d635683b524381c3d084498ec7aa (patch)
treeeebdad218b0d6a0c1bf7cd13358d488d1d69d146 /tests/Makefile.am
parente2fa7956b87c23a8229926f39a3863ecd4d4752a (diff)
downloadlibsandglass-d69067be2350d635683b524381c3d084498ec7aa.tar.xz
Add more tests.
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am18
1 files changed, 17 insertions, 1 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index ee8a2f1..b4fd06d 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -17,10 +17,26 @@
## along with this program. If not, see <http://www.gnu.org/licenses/>. ##
###########################################################################
-check_PROGRAMS = introspective-system-test
+check_PROGRAMS = introspective-system-test \
+ introspective-cputime-test \
+ monotonic-system-test \
+ monotonic-cputime-test \
+ monotonic-realticks-test
TESTS = $(check_PROGRAMS)
INCLUDES = -I../src
introspective_system_test_SOURCES = introspective-system.c
introspective_system_test_LDADD = ../src/libsandglass.la
+
+introspective_cputime_test_SOURCES = introspective-cputime.c
+introspective_cputime_test_LDADD = ../src/libsandglass.la
+
+monotonic_system_test_SOURCES = monotonic-system.c
+monotonic_system_test_LDADD = ../src/libsandglass.la
+
+monotonic_cputime_test_SOURCES = monotonic-cputime.c
+monotonic_cputime_test_LDADD = ../src/libsandglass.la
+
+monotonic_realticks_test_SOURCES = monotonic-realticks.c
+monotonic_realticks_test_LDADD = ../src/libsandglass.la