summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorTavian Barnes <tavianator@gmail.com>2009-09-17 03:18:34 +0000
committerTavian Barnes <tavianator@gmail.com>2009-09-17 03:18:34 +0000
commitfb147c5f6570a971ae25d07c74f94f6d2fdcb130 (patch)
tree2a8966cdec2a77f9e28123347f1791b041ef2143 /configure.ac
parent01eb59bb3061bbdf9feaaf3d5b4e1258526106bb (diff)
downloadlibsandglass-fb147c5f6570a971ae25d07c74f94f6d2fdcb130.tar.xz
Add build system.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac49
1 files changed, 49 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 0000000..f5ce243
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,49 @@
+dnl Copyright (C) 2008 Tavian Barnes <tavianator@gmail.com>
+dnl
+dnl This file is part of The Sandglass Library.
+dnl
+dnl The Sandglass Library is free software; you can redistribute it
+dnl and/or modify it under the terms of the GNU Lesser General Public
+dnl License as published by the Free Software Foundation; either version
+dnl 3 of the License, or (at your option) any later version.
+dnl
+dnl The Sandglass Library is distributed in the hope that it will be
+dnl useful, but WITHOUT ANY WARRANTY; without even the implied warranty
+dnl of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+dnl Lesser General Public License for more details.
+dnl
+dnl You should have received a copy of the GNU Lesser General Public
+dnl License along with this program. If not, see
+dnl <http://www.gnu.org/licenses/>.
+
+AC_PREREQ(2.63)
+AC_INIT(The Sandglass Library, 0.0.0, tavianator@gmail.com, libsandglass)
+AM_INIT_AUTOMAKE(libsandglass, 0.0.0)
+
+dnl Programs
+AC_PROG_CC
+AC_PROG_CXX
+AM_PROG_CC_C_O
+AM_PROG_AS
+AC_PROG_INSTALL
+AC_PROG_LN_S
+AC_PROG_MAKE_SET
+AC_PROG_LIBTOOL
+
+dnl Checks for header files.
+AC_CHECK_HEADERS([stddef.h stdlib.h time.h unistd.h])
+
+dnl Checks for typedefs, structures, and compiler characteristics.
+AC_TYPE_SIZE_T
+
+dnl Find out which assembly files to compile
+AC_CANONICAL_HOST
+
+AM_CONDITIONAL([X86], [echo $host_cpu | grep '.*86$' >/dev/null])
+AM_CONDITIONAL([X86_64], [echo $host_cpu | grep 'x86_64$' >/dev/null])
+
+dnl Generate Makefiles
+AC_CONFIG_MACRO_DIR([m4])
+AC_CONFIG_FILES([Makefile
+ src/Makefile])
+AC_OUTPUT