summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorTavian Barnes <tavianator@gmail.com>2010-03-06 13:22:59 -0500
committerTavian Barnes <tavianator@gmail.com>2010-03-06 13:22:59 -0500
commitb31647ec5bc1979a0accfd8e89936d0d943734f1 (patch)
treef41905a5b3079764e23fd1d8a5203bdc148eb024 /configure.ac
parent6952438ad1ef40132f8c00aa850fa558fe2202c1 (diff)
downloadlibsandglass-b31647ec5bc1979a0accfd8e89936d0d943734f1.tar.xz
Make build work on non-x86/x86_64 platforms.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 4 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index d81b8e6..c0b1000 100644
--- a/configure.ac
+++ b/configure.ac
@@ -39,6 +39,8 @@ AC_TYPE_SIZE_T
dnl Find out which assembly files to compile
AC_CANONICAL_HOST
+tsc=0
+
if echo $host_cpu | grep '86$' 2>&1 >/dev/null
then
arch_x86=1
@@ -54,8 +56,8 @@ fi
AM_CONDITIONAL([X86], [test "$arch_x86"])
AM_CONDITIONAL([X86_64], [test "$arch_x86_64"])
-AC_DEFINE([SANDGLASS_TSC], ["$tsc"])
-AM_CONDITIONAL([TSC], [test "$tsc"])
+AC_DEFINE_UNQUOTED([SANDGLASS_TSC], [$tsc])
+AM_CONDITIONAL([TSC], [test "$tsc" -ne 0])
dnl Generate Makefiles
AC_CONFIG_MACRO_DIR([m4])