summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorTavian Barnes <tavianator@gmail.com>2009-09-17 03:18:51 +0000
committerTavian Barnes <tavianator@gmail.com>2009-09-17 03:18:51 +0000
commit66084b816dd25a41f774240328a31d57efd276e4 (patch)
treeacd22d0e3eb5f5608184fc18479e8890906cbe7f /configure.ac
parentf46ea7eb1b6f55036f10b6ae919c1785cb72c836 (diff)
downloadlibsandglass-66084b816dd25a41f774240328a31d57efd276e4.tar.xz
Begin libsandglass implementation.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac20
1 files changed, 16 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 044ea79..deea2b8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -17,8 +17,8 @@ dnl License along with this program. If not, see
dnl <http://www.gnu.org/licenses/>.
AC_PREREQ(2.63)
-AC_INIT(The Sandglass Library, 0.0.0, tavianator@gmail.com, libsandglass)
-AM_INIT_AUTOMAKE(libsandglass, 0.0.0)
+AC_INIT(The Sandglass Library, 0.0, tavianator@gmail.com, libsandglass)
+AM_INIT_AUTOMAKE(libsandglass, 0.0)
dnl Programs
AC_PROG_CC
@@ -39,8 +39,20 @@ AC_TYPE_SIZE_T
dnl Find out which assembly files to compile
AC_CANONICAL_HOST
-AM_CONDITIONAL([X86], [echo $host_cpu | grep '.*86$' >/dev/null])
-AM_CONDITIONAL([X86_64], [echo $host_cpu | grep 'x86_64$' >/dev/null])
+if echo $host_cpu | grep '86$' 2>&1 >/dev/null
+then
+ arch_x86="true"
+ AC_DEFINE([SANDGLASS_TSC])
+fi
+
+if echo $host_cpu | grep 'x86_64$' 2>&1 >/dev/null
+then
+ arch_x86_64="true"
+ AC_DEFINE([SANDGLASS_TSC])
+fi
+
+AM_CONDITIONAL([X86], [test "$arch_x86"])
+AM_CONDITIONAL([X86_64], [test "$arch_x86_64"])
dnl Generate Makefiles
AC_CONFIG_MACRO_DIR([m4])