summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorTavian Barnes <tavianator@gmail.com>2009-09-18 19:47:51 +0000
committerTavian Barnes <tavianator@gmail.com>2009-09-18 19:47:51 +0000
commite2fa7956b87c23a8229926f39a3863ecd4d4752a (patch)
tree89008fd214693cf8b5df22b9b492fcd3f394e0cb /configure.ac
parent25052f0997c75f91846511041cf4eeb20959ae96 (diff)
downloadlibsandglass-e2fa7956b87c23a8229926f39a3863ecd4d4752a.tar.xz
Add timespec helper routines.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 7 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index deea2b8..c767daa 100644
--- a/configure.ac
+++ b/configure.ac
@@ -41,19 +41,22 @@ AC_CANONICAL_HOST
if echo $host_cpu | grep '86$' 2>&1 >/dev/null
then
- arch_x86="true"
- AC_DEFINE([SANDGLASS_TSC])
+ arch_x86=1
+ tsc=1
fi
if echo $host_cpu | grep 'x86_64$' 2>&1 >/dev/null
then
- arch_x86_64="true"
- AC_DEFINE([SANDGLASS_TSC])
+ arch_x86_64=1
+ tsc=1
fi
AM_CONDITIONAL([X86], [test "$arch_x86"])
AM_CONDITIONAL([X86_64], [test "$arch_x86_64"])
+AC_DEFINE([SANDGLASS_TSC], ["$tsc"])
+AM_CONDITIONAL([TSC], [test "$tsc"])
+
dnl Generate Makefiles
AC_CONFIG_MACRO_DIR([m4])
AC_CONFIG_FILES([Makefile