summaryrefslogtreecommitdiffstats
path: root/dimension/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'dimension/Makefile.am')
-rw-r--r--dimension/Makefile.am12
1 files changed, 11 insertions, 1 deletions
diff --git a/dimension/Makefile.am b/dimension/Makefile.am
index cd0603f..c12a6b7 100644
--- a/dimension/Makefile.am
+++ b/dimension/Makefile.am
@@ -20,4 +20,14 @@
SUBDIRS = . \
tests
-bin_SCRIPTS = dimension
+dist_bin_SCRIPTS = dimension
+
+# make distcheck fails on the client because Python cannot find the module,
+# since it's not really installed, so disable the --help and --version checks
+AM_INSTALLCHECK_STD_OPTIONS_EXEMPT = dimension
+
+pkgpython_PYTHON = __init__.py
+nodist_pkgpython_PYTHON = client.py
+
+clean-local:
+ rm -rf __pycache__/