summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 12 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index bafc63e..5652aff 100644
--- a/configure.ac
+++ b/configure.ac
@@ -49,7 +49,7 @@ AC_ARG_ENABLE([png],
if test "$enable_png" != "no"; then
PKG_CHECK_MODULES([libpng], [libpng], [enable_png=yes],
[test "$enable_png" = "yes" && AC_MSG_ERROR([libpng not found])
- enable_png-no])
+ enable_png=no])
AC_SUBST(libpng_CFLAGS)
AC_SUBST(libpng_LIBS)
fi
@@ -76,6 +76,17 @@ AC_ARG_ENABLE([profile],
[enable_profile=no])
AM_CONDITIONAL([PROFILE], [test "$enable_profile" = "yes"])
+dnl Debug/release builds
+AC_ARG_ENABLE([debug],
+ [AS_HELP_STRING([--enable-debug],
+ [Perform potentially expensive sanity checks while running [default=no]])],
+ [],
+ [enable_debug=no])
+if test "$enable_debug" = "no"; then
+ AC_DEFINE([NDEBUG], [1])
+fi
+AM_CONDITIONAL([DEBUG], [test "$enable_debug" = "yes"])
+
dnl Python headers
PKG_CHECK_MODULES([Python], [python3 >= 3.2],
[],