summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 9 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 503262a..2849b10 100644
--- a/configure.ac
+++ b/configure.ac
@@ -28,11 +28,18 @@ AC_PROG_LN_S
AC_PROG_MAKE_SET
AC_PROG_LIBTOOL
+dnl Timing library for benchmarks
+AC_CHECK_LIB([sandglass], [sandglass_create],
+ [],
+ [AC_MSG_WARN([libsandglass not found - benchmarking suite will not work correctly])])
+
dnl Generate Makefiles
AC_CONFIG_MACRO_DIR([m4])
AC_CONFIG_FILES([Makefile
- doc/Makefile
libdimension/Makefile
tests/Makefile
- tests/libdimension/Makefile])
+ tests/libdimension/Makefile
+ bench/Makefile
+ bench/libdimension/Makefile
+ doc/Makefile])
AC_OUTPUT