summaryrefslogtreecommitdiffstats
path: root/tests/libdimension/Makefile.am
diff options
context:
space:
mode:
authorTavian Barnes <tavianator@gmail.com>2010-05-06 15:18:33 -0600
committerTavian Barnes <tavianator@gmail.com>2010-05-06 15:18:33 -0600
commit4031fef0bba9575d1c9d45af06b3a9996311880c (patch)
tree3143adae8c5ac273e2538f200efbd1b6405b2364 /tests/libdimension/Makefile.am
parent9c35f4d740762bdc302853df590d9f513368ae17 (diff)
downloaddimension-4031fef0bba9575d1c9d45af06b3a9996311880c.tar.xz
Only render in one combined `render' test.
GL and PNG tests now only test import/export.
Diffstat (limited to 'tests/libdimension/Makefile.am')
-rw-r--r--tests/libdimension/Makefile.am14
1 files changed, 8 insertions, 6 deletions
diff --git a/tests/libdimension/Makefile.am b/tests/libdimension/Makefile.am
index f59848e..21275fd 100644
--- a/tests/libdimension/Makefile.am
+++ b/tests/libdimension/Makefile.am
@@ -22,9 +22,10 @@ INCLUDES = -I$(top_srcdir)/libdimension
check_LTLIBRARIES = libdimension-tests.la
check_PROGRAMS = error-test \
warning-test \
- prtree-test \
+ prtree-test \
png-test \
gl-test \
+ render-test \
cxx-test
TESTS = $(check_PROGRAMS)
XFAIL_TESTS = error-test
@@ -37,9 +38,6 @@ if !GL
XFAIL_TESTS += gl-test
endif
-.PHONY: clean-local-png-test
-clean-local: clean-local-png-test
-
libdimension_tests_la_SOURCES = tests.c tests.h
if PGO
@@ -61,11 +59,15 @@ prtree_test_LDADD = libdimension-tests.la
png_test_SOURCES = png.c
png_test_LDADD = libdimension-tests.la
-clean-local-png-test:
- rm -f *.png
gl_test_SOURCES = gl.c
gl_test_LDADD = libdimension-tests.la
+render_test_SOURCES = render.c
+render_test_LDADD = libdimension-tests.la
+
cxx_test_SOURCES = cxx.cpp
cxx_test_LDADD = libdimension-tests.la
+
+clean-local:
+ rm -f *.png