summaryrefslogtreecommitdiffstats
path: root/libdimension-python/tests/Makefile.am
diff options
context:
space:
mode:
authorTavian Barnes <tavianator@gmail.com>2011-05-16 15:30:23 -0600
committerTavian Barnes <tavianator@gmail.com>2011-05-16 15:30:23 -0600
commit065846d055c9c0956fe4bf1762d81a4b72b5d5a8 (patch)
treee607f8a761324f8a333a9cfc4151fe1ea34d4725 /libdimension-python/tests/Makefile.am
parent87bc3cb4fcaf0e3ead4c41e8c56a06cf481875c0 (diff)
downloaddimension-065846d055c9c0956fe4bf1762d81a4b72b5d5a8.tar.xz
Split python Scenes into a new source file, add python tests.
Diffstat (limited to 'libdimension-python/tests/Makefile.am')
-rw-r--r--libdimension-python/tests/Makefile.am29
1 files changed, 29 insertions, 0 deletions
diff --git a/libdimension-python/tests/Makefile.am b/libdimension-python/tests/Makefile.am
new file mode 100644
index 0000000..4bebfda
--- /dev/null
+++ b/libdimension-python/tests/Makefile.am
@@ -0,0 +1,29 @@
+###########################################################################
+## Copyright (C) 2009-2011 Tavian Barnes <tavianator@tavianator.com> ##
+## ##
+## This file is part of The Dimension Build Suite. ##
+## ##
+## The Dimension Build Suite is free software; you can redistribute it ##
+## and/or modify it under the terms of the GNU General Public License as ##
+## published by the Free Software Foundation; either version 3 of the ##
+## License, or (at your option) any later version. ##
+## ##
+## The Dimension Build Suite is distributed in the hope that it will be ##
+## useful, but WITHOUT ANY WARRANTY; without even the implied warranty ##
+## of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU ##
+## General Public License for more details. ##
+## ##
+## You should have received a copy of the GNU General Public License ##
+## along with this program. If not, see <http://www.gnu.org/licenses/>. ##
+###########################################################################
+
+TESTS = demo.py
+TESTS_ENVIRONMENT = PYTHONPATH=$(top_builddir)/libdimension-python/.libs
+
+.py:
+ cp $(srcdir)/$@ .
+
+EXTRA_DIST = $(TESTS)
+
+clean-local:
+ rm -f *.png