summaryrefslogtreecommitdiffstats
path: root/dimension/tests/Makefile.am
diff options
context:
space:
mode:
authorTavian Barnes <tavianator@gmail.com>2011-05-15 15:54:56 -0600
committerTavian Barnes <tavianator@gmail.com>2011-05-15 15:58:05 -0600
commita5a6b94c038e01ebf1e2de0a0774a69b02fb8e1e (patch)
tree66a4b977fff9f0119456b6c5a3398d25976f6c53 /dimension/tests/Makefile.am
parent130cbc32499ade9235873bc5d575816f80636916 (diff)
downloaddimension-a5a6b94c038e01ebf1e2de0a0774a69b02fb8e1e.tar.xz
Group tests and benchmarks with the corresponding source code.
Diffstat (limited to 'dimension/tests/Makefile.am')
-rw-r--r--dimension/tests/Makefile.am55
1 files changed, 55 insertions, 0 deletions
diff --git a/dimension/tests/Makefile.am b/dimension/tests/Makefile.am
new file mode 100644
index 0000000..c54bcd4
--- /dev/null
+++ b/dimension/tests/Makefile.am
@@ -0,0 +1,55 @@
+###########################################################################
+## Copyright (C) 2009-2010 Tavian Barnes <tavianator@tavianator.com> ##
+## ##
+## This file is part of The Dimension Build Suite. ##
+## ##
+## The Dimension Build Suite is free software; you can redistribute it ##
+## and/or modify it under the terms of the GNU General Public License as ##
+## published by the Free Software Foundation; either version 3 of the ##
+## License, or (at your option) any later version. ##
+## ##
+## The Dimension Build Suite is distributed in the hope that it will be ##
+## useful, but WITHOUT ANY WARRANTY; without even the implied warranty ##
+## of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU ##
+## General Public License for more details. ##
+## ##
+## You should have received a copy of the GNU General Public License ##
+## along with this program. If not, see <http://www.gnu.org/licenses/>. ##
+###########################################################################
+
+INCLUDES = -I$(top_srcdir)/libdimension
+
+TESTS = punctuation.sh \
+ numeric.sh \
+ strings.sh \
+ labels.sh \
+ directives.sh \
+ arithexp.sh \
+ transformations.sh \
+ invalid-macro.sh \
+ tbuffer-overlap.sh \
+ integer-overflow.sh \
+ csg.sh \
+ demo.sh
+TESTS_ENVIRONMENT = top_builddir=$(top_builddir) dimension_flags=--strict
+
+.sh:
+ cp $(srcdir)/$@ .
+
+EXTRA_DIST = $(TESTS) \
+ punctuation.pov \
+ numeric.pov \
+ strings.pov \
+ labels.pov \
+ directives.inc \
+ directives.pov \
+ arithexp.pov \
+ transformations.pov \
+ invalid-macro.pov \
+ tbuffer-overlap.pov \
+ integer-overflow.pov \
+ csg.pov \
+ demo.pov
+
+clean-local:
+ rm -f *.png