summaryrefslogtreecommitdiffstats
path: root/dimension/Makefile.am
diff options
context:
space:
mode:
authorTavian Barnes <tavianator@gmail.com>2011-10-31 17:59:56 -0400
committerTavian Barnes <tavianator@gmail.com>2011-10-31 23:22:26 -0400
commitcff94b97ca2e3a4b7396845a7a2fd1c9ab812d55 (patch)
tree814b963d690ef08057b461e9103d3fa31a4c2e72 /dimension/Makefile.am
parent2e77183461e11521a37f34e0c01581df762413fc (diff)
downloaddimension-cff94b97ca2e3a4b7396845a7a2fd1c9ab812d55.tar.xz
Ship dimension client inside the Python package.
Diffstat (limited to 'dimension/Makefile.am')
-rw-r--r--dimension/Makefile.am12
1 files changed, 11 insertions, 1 deletions
diff --git a/dimension/Makefile.am b/dimension/Makefile.am
index cd0603f..c12a6b7 100644
--- a/dimension/Makefile.am
+++ b/dimension/Makefile.am
@@ -20,4 +20,14 @@
SUBDIRS = . \
tests
-bin_SCRIPTS = dimension
+dist_bin_SCRIPTS = dimension
+
+# make distcheck fails on the client because Python cannot find the module,
+# since it's not really installed, so disable the --help and --version checks
+AM_INSTALLCHECK_STD_OPTIONS_EXEMPT = dimension
+
+pkgpython_PYTHON = __init__.py
+nodist_pkgpython_PYTHON = client.py
+
+clean-local:
+ rm -rf __pycache__/