summaryrefslogtreecommitdiffstats
path: root/build/pkgs.mk
diff options
context:
space:
mode:
authorTavian Barnes <tavianator@tavianator.com>2024-05-24 09:37:57 -0400
committerTavian Barnes <tavianator@tavianator.com>2024-05-24 14:23:50 -0400
commit3a6c1f049bb3643c86eb87f6c69cf7c3d3c95c86 (patch)
tree8793e871cc4ee1b3d3ff82b73d04c9264aaf12a9 /build/pkgs.mk
parent64fcb1d975e8ec8ac70f7ae8add2f7499e6fe6e9 (diff)
downloadbfs-3a6c1f049bb3643c86eb87f6c69cf7c3d3c95c86.tar.xz
configure: Use --with/--without for libraries
Diffstat (limited to 'build/pkgs.mk')
-rw-r--r--build/pkgs.mk10
1 files changed, 5 insertions, 5 deletions
diff --git a/build/pkgs.mk b/build/pkgs.mk
index 5a26548..5de9ac2 100644
--- a/build/pkgs.mk
+++ b/build/pkgs.mk
@@ -8,7 +8,7 @@ include gen/vars.mk
include gen/flags.mk
include build/exports.mk
-HEADERS := ${ALL_PKGS:%=gen/use/%.h}
+HEADERS := ${ALL_PKGS:%=gen/with/%.h}
gen/pkgs.mk: ${HEADERS}
${MSG} "[ GEN] $@"
@@ -24,10 +24,10 @@ gen/pkgs.mk: ${HEADERS}
.PHONY: gen/pkgs.mk
-# Convert gen/use/foo.h to foo
-PKG = ${@:gen/use/%.h=%}
+# Convert gen/with/foo.h to foo
+PKG = ${@:gen/with/%.h=%}
${HEADERS}::
@${MKDIR} ${@D}
- @build/define-if.sh use/${PKG} build/pkgconf.sh ${PKG} >$@ 2>$@.log; \
- build/msg-if.sh "[ CC ] use/${PKG}.c" test $$? -eq 0;
+ @build/define-if.sh with/${PKG} build/pkgconf.sh ${PKG} >$@ 2>$@.log; \
+ build/msg-if.sh "[ CC ] with/${PKG}.c" test $$? -eq 0;